Carte son integrée à K7S5A

Le
Anthony
Bonjour,

J'ai une Slackware 9,0 et il me reste plus que la carte son a installer,
c'est une carte son integrée a la carte mere EliteGroup K7S5A. J'ai lu les
artciles sur le net : le K7S5A-Howto, la doc de Lea et la documentation de
du site officiel de Alsa.
D'apres le Howto, la carte son serait une Sis 7012 et utilserait le module
snd-intel8x0 ; mais qd je lance xmms j'ai les messages d'erreur suivants :
1) Le msg d'erreur au lancement de xmms :
libmikmod.so.2: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type
2) Le msg d'erreur qd je veux lire un fichier :
** WARNING **: SNDCTL_DSP_SETFMT ioctl failed: Argument invalide
Bon la je vois pas quoi faire si qq'un a une idée

En fait le truc c'est que le Pc que j'ai actuellement n'est pas a moi,
c'est celui d'un copain qui me le prete pour les vacances, donc je
connaissais pas le matos. Comme il avait Windows Xp, je suis alle ds le
gestionnaire de peripheriques et la carte son est reconnue comme une
C-Media CMIxxxx. D'apres la description de la carte mere sur le site de
EliteGroup, la CM a une carte son C-Media CMI9738, or ce type de carte
n'est pas mentionnée sur le site officiel de Alsa, il y a en revanche la
C-Media CMI8738.
Donc est-ce que qq'un pourrait-il m'en dire plus sur ce carte mere et
cette mysterieuse carte son ?

Merci par avance

Anthony
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Florian
Le #455227
tu peux utiliser le module snd--intel8x0, c'est ca qui fonctionne sous mdk
9.1, par contre il faut rajouter, dans la config, je sais plus ou je l'ai
fait en graphique :(
enable = yes
c'est tout con, mais à cause de ca, je n'avais pas de son, c'est
probablement le même genre de truc
Julien `soda` Delange
Le #455226
On Sat, 26 Jul 2003 13:46:55 +0200, Anthony wrote:

Bonjour,

J'ai une Slackware 9,0 et il me reste plus que la carte son a installer,
c'est une carte son integrée a la carte mere EliteGroup K7S5A. J'ai lu les
artciles sur le net : le K7S5A-Howto, la doc de Lea et la documentation de
du site officiel de Alsa.
D'apres le Howto, la carte son serait une Sis 7012 et utilserait le module
snd-intel8x0 ; mais qd je lance xmms j'ai les messages d'erreur suivants :
1) Le msg d'erreur au lancement de xmms :
libmikmod.so.2: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type
2) Le msg d'erreur qd je veux lire un fichier :


Attention ... il faut charger le module, donc, faire un :
modprobe i810_audio (pour quelque chose dans le genre, dans votre cas, ce
serait plus snd-intel8x0 , mais ça, ce sont les modules ALSA).


** WARNING **: SNDCTL_DSP_SETFMT ioctl failed: Argument invalide
Bon la je vois pas quoi faire si qq'un a une idée ...



Xmms fait une erreur, car Unix gere les périphérique comme des fichiers,
et là, il ne peut écrire dans le fichier pour le son ...


Merci par avance
De rien ;-)


Anthony
Le #455004
Le Sat, 26 Jul 2003 14:58:52 +0200, Florian a écrit :

tu peux utiliser le module snd--intel8x0, c'est ca qui fonctionne sous mdk
9.1, par contre il faut rajouter, dans la config, je sais plus ou je l'ai
fait en graphique :(
enable = yes
c'est tout con, mais à cause de ca, je n'avais pas de son, c'est
probablement le même genre de truc


Oui merci je me doute que ca doit etre tout con, mais j'y arrive pas. Si
tu pouvais me poster ton /etc/modules.conf ca serait cool, merci. Et aussi
pourrais-tu me dire plus precisement ou est-ce qu'il faut que je mettre
enable=yes ?

Merci

Anthony

Anthony
Le #462250
Attention ... il faut charger le module, donc, faire un :
modprobe i810_audio (pour quelque chose dans le genre, dans votre cas, ce
serait plus snd-intel8x0 , mais ça, ce sont les modules ALSA).
Oui j'ai bien fait tout ce mais ca ne marche tjs pas, j'ai tjs le message

d'erreur suivant :
** WARNING **: SNDCTL_DSP_SETFMT ioctl failed: Argument invalide
** WARNING **: SNDCTL_DSP_SPEED ioctl failed: Argument invalide

** WARNING **: SNDCTL_DSP_SETFMT ioctl failed: Argument invalide
Bon la je vois pas quoi faire si qq'un a une idée ...



Xmms fait une erreur, car Unix gere les périphérique comme des fichiers,
et là, il ne peut écrire dans le fichier pour le son ...
Ok, merci ca je le savais deja, mais pourquoi il peut ecrire ds ce fichier

? Qq'un a-t-il une idée ?

Merci qd meme.


seb666fr2
Le #466333
"Anthony"
Bonjour,

J'ai une Slackware 9,0 et il me reste plus que la carte son a installer,
c'est une carte son integrée a la carte mere EliteGroup K7S5A. J'ai lu les
artciles sur le net : le K7S5A-Howto, la doc de Lea et la documentation de
du site officiel de Alsa.
D'apres le Howto, la carte son serait une Sis 7012 et utilserait le module
snd-intel8x0 ; mais qd je lance xmms j'ai les messages d'erreur suivants :
1) Le msg d'erreur au lancement de xmms :
libmikmod.so.2: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type
2) Le msg d'erreur qd je veux lire un fichier :
** WARNING **: SNDCTL_DSP_SETFMT ioctl failed: Argument invalide
Bon la je vois pas quoi faire si qq'un a une idée ...

En fait le truc c'est que le Pc que j'ai actuellement n'est pas a moi,
c'est celui d'un copain qui me le prete pour les vacances, donc je
connaissais pas le matos. Comme il avait Windows Xp, je suis alle ds le
gestionnaire de peripheriques et la carte son est reconnue comme une
C-Media CMIxxxx. D'apres la description de la carte mere sur le site de
EliteGroup, la CM a une carte son C-Media CMI9738, or ce type de carte
n'est pas mentionnée sur le site officiel de Alsa, il y a en revanche la
C-Media CMI8738.
Donc est-ce que qq'un pourrait-il m'en dire plus sur ce carte mere et
cette mysterieuse carte son ?

Merci par avance

Anthony


Salut,

j'ai eu le même genre de pb lorsque j'ai installé la slack 8.1. Pour
corriger ce pb, essai d'ajouter une ligne 'alias sound-slot-0
i810_audio' dans
/etc/modules.conf

A+
Seb

Anthony
Le #473593
Le Tue, 29 Jul 2003 07:27:23 -0700, Sébastien BALLET a écrit :

"Anthony"
Bonjour,

J'ai une Slackware 9,0 et il me reste plus que la carte son a installer,
c'est une carte son integrée a la carte mere EliteGroup K7S5A. J'ai lu les
artciles sur le net : le K7S5A-Howto, la doc de Lea et la documentation de
du site officiel de Alsa.
D'apres le Howto, la carte son serait une Sis 7012 et utilserait le module
snd-intel8x0 ; mais qd je lance xmms j'ai les messages d'erreur suivants :
1) Le msg d'erreur au lancement de xmms :
libmikmod.so.2: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type
2) Le msg d'erreur qd je veux lire un fichier :
** WARNING **: SNDCTL_DSP_SETFMT ioctl failed: Argument invalide
Bon la je vois pas quoi faire si qq'un a une idée ...

En fait le truc c'est que le Pc que j'ai actuellement n'est pas a moi,
c'est celui d'un copain qui me le prete pour les vacances, donc je
connaissais pas le matos. Comme il avait Windows Xp, je suis alle ds le
gestionnaire de peripheriques et la carte son est reconnue comme une
C-Media CMIxxxx. D'apres la description de la carte mere sur le site de
EliteGroup, la CM a une carte son C-Media CMI9738, or ce type de carte
n'est pas mentionnée sur le site officiel de Alsa, il y a en revanche la
C-Media CMI8738.
Donc est-ce que qq'un pourrait-il m'en dire plus sur ce carte mere et
cette mysterieuse carte son ?

Merci par avance

Anthony


Salut,

j'ai eu le même genre de pb lorsque j'ai installé la slack 8.1. Pour
corriger ce pb, essai d'ajouter une ligne 'alias sound-slot-0
i810_audio' dans
/etc/modules.conf

A+
Seb


OK merci je prends note, j'essayerai a l'occasion. Là j'ai finis par
abandonner et j'ai mis ma SB Live qui a fonctionné sans aucun pb. Et comme
j'aime pas rester sur un echec j'essyaerai un peu plus tard, pour
l'instant je suis entrain d'installer la LFS.
Merci a vous tous !

Anthony


Poster une réponse
Anonyme