Copie formule rechercheV avec VBA

Le
Patrick
Bonjour à toutes et tous,

Débutant en VBA, je coince sur une macro:

Je voudrais copier à l'aide d'une macro sur une colonne entière la formule
de la cellule supérieure qui contient une formule type rechercheV
=RECHERCHEV(A2;$F$10:$G$20;2)
En fait, je n'arrive pas à incrémenter la valeur cherchée en VBA Ex: A2, A3,
A4 etc.

Please help


merci d'avance

Patrick
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
FxM
Le #3836331
Bonjour Patrick,

Tu cherches à remplir (FILL) vers le bas (DOWN).

Extrait de l'aide (touche F1) pour .filldown :
Cet exemple montre comment remplir la plage A1:A10 dans la feuille
Sheet1, basée sur le contenu de la cellule A1.
Worksheets("Sheet1").Range("A1:A10").FillDown

@+
FxM


Bonjour à toutes et tous,

Débutant en VBA, je coince sur une macro:

Je voudrais copier à l'aide d'une macro sur une colonne entière la formule
de la cellule supérieure qui contient une formule type rechercheV
=RECHERCHEV(A2;$F$10:$G$20;2)
En fait, je n'arrive pas à incrémenter la valeur cherchée en VBA Ex: A2, A3,
A4 etc..........

Please help


merci d'avance

Patrick




FL
Le #3836321
Bonjour,
Si tu recherches A2 dans la sélection $F$10:$G$20
puis A3 dans la même sélection il faut que tu notes $A2 au lieu de A2

=RECHERCHEV($A2;$F10:$G$20;2)


à+
FL

"Patrick" 44f2da69$0$29483$
Bonjour à toutes et tous,

Débutant en VBA, je coince sur une macro:

Je voudrais copier à l'aide d'une macro sur une colonne entière la formule
de la cellule supérieure qui contient une formule type rechercheV
=RECHERCHEV(A2;$F$10:$G$20;2)
En fait, je n'arrive pas à incrémenter la valeur cherchée en VBA Ex: A2,
A3, A4 etc..........

Please help


merci d'avance

Patrick



FL
Le #3836291
Bonjour,
Si tu recherches A2 dans la sélection $F$10:$G$20
puis A3 dans la même sélection il faut que tu notes $A2 au lieu de A2

=RECHERCHEV($A2;$F$10:$G$20;2)

il y avait un $ qui s'était perdu.


à+
FL

"Patrick" 44f2da69$0$29483$
Bonjour à toutes et tous,

Débutant en VBA, je coince sur une macro:

Je voudrais copier à l'aide d'une macro sur une colonne entière la formule
de la cellule supérieure qui contient une formule type rechercheV
=RECHERCHEV(A2;$F$10:$G$20;2)
En fait, je n'arrive pas à incrémenter la valeur cherchée en VBA Ex: A2,
A3, A4 etc..........

Please help


merci d'avance

Patrick



Patrick
Le #3836231
Merci ça marche

Patrick

"FxM"
Bonjour Patrick,

Tu cherches à remplir (FILL) vers le bas (DOWN).

Extrait de l'aide (touche F1) pour .filldown :
Cet exemple montre comment remplir la plage A1:A10 dans la feuille Sheet1,
basée sur le contenu de la cellule A1.
Worksheets("Sheet1").Range("A1:A10").FillDown

@+
FxM


Bonjour à toutes et tous,

Débutant en VBA, je coince sur une macro:

Je voudrais copier à l'aide d'une macro sur une colonne entière la
formule de la cellule supérieure qui contient une formule type rechercheV
=RECHERCHEV(A2;$F$10:$G$20;2)
En fait, je n'arrive pas à incrémenter la valeur cherchée en VBA Ex: A2,
A3, A4 etc..........

Please help


merci d'avance

Patrick




Poster une réponse
Anonyme