[dde d'assistance] carte wifi "introuvable" (virée de la configuration mal encontreusement)

Le
Bernard THOMAS
Bonjour le groupe,
je viens de alt.fr.comp.reseaux.wifi où j'ai posé la même question en
vain. Les échanges m'ont juste permis de mieux formuler le problème.
Mandriva2006 en dual boot avec un XP
une carte wifi Intel Pro wireless 2200BG (qui fonctionne parfaitement
sous XP) et qui a fonctionné quelques temps sous linux. Puis s'est arrêtée.
J'ai essayé de remettre la config en ordre et j'ai bien l'impression
d'avoir mis plus de désordre qu'avant. J'ai perdu eth1 et je n'arrive
plus du tout à la retrouver.

1. Si je passe par les fenêtres du panneau de config, je ne peux plus
rajouter la connexion wifi car elle n'est pas reconnue automatiquement
(bien qu'on me propose inconnu (ipw2200) avec le nom complet de la
carte. Toute tentative se solde par "Aucun périphérique trouvé". Si je
veux la rajouter manuellement, je suis largué sur plusieurs paramètres à
indiquer : disable, associate, auto_create, led, debug, channel, mode,
hwcrypto. Le plus corsé est quand même debug output mask

2. J'ai commencé à faire un comparatif entre ce qui est raconté dans la
doc' d'installation de la carte wifi
(http://ipw2100.sourceforge.net/INSTALL) et ma situation pour tenter de
trouver l'erreur. Je ne m'en sors pas avec le niveau que j'ai :-(
Voici les commandes du début de la doc':
# lspci | grep 2200
02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)

Il me manque un module car:
# lsmod | grep 2200
ne renvoie rien.

J'ai des messages avec eth1 dans mes log systèmes. Je peux les publier
si cela aide. On doit y voir les traces de la désinstallation que j'ai
tentée pour ensuite essayer de recréer l'interface réseau wifi en état
de marche. Mais je ne suis pas sûr que cela aide beaucoup.

Qui maitrise bien la mise en oeuvre de cette carte (ou d'une autre) et
pourrait m'aider à remettre le système en ordre pas à pas ? Cela
m'intéresse aussi nettement pour la compréhension de linux.

En vous remerciant pour l'attention à ce message, cordialement
Bernard
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
triaxx
Le #8043181
Désolé, mais je ne possède pas cette carte et je ne l'ai encore moins
installé.
lspci reconnait que ta carte est installé, donc le système la gère, mais
aucun module n'est chargé. Essaye la commande : modprobe ipw2200 pour
charger le module qui va bien.
Ensuite, la command ifconfig -a permet d'afficher toutes les interfaces
réseaux reconnues par le système, même si elles ne sont pas encore
configurées. Si ta carte apparaît, tu devrais pouvoir la configurer via
les utilitaires Mandriva.

Bon courage et bonne chance.
none
Le #8043161
Bernard THOMAS a écrit :
Bonjour le groupe,
je viens de alt.fr.comp.reseaux.wifi où j'ai posé la même question en
vain. Les échanges m'ont juste permis de mieux formuler le problème.
Mandriva2006 en dual boot avec un XP
une carte wifi Intel Pro wireless 2200BG (qui fonctionne parfaitement
sous XP) et qui a fonctionné quelques temps sous linux. Puis s'est arrêtée.


Pour ma part, j'ai eu moult problèmes avec le toshiba de mon fils ; en
fait, il y a un problème entre l'acpi et le wifi. Essaye de désactiver
l'acpi, le wifi devrait remarcher.

Perso, j'ai réussi à faire fonctionner les deux (wifi et acpi) avec le
kernel 2.6.15-rc4 ; j'ai essayé, il y a peu, d'installer un kernel plus
récent, mais les problèmes ont resurgi alors je suis revenu au kernel
précédent :(

Le problème vient peut-être d'un partage d'interuption mal géré... je ne
me souviens plus.

Moralité : on a tjrs tort de ne pas noter le mode de résolution d'un
problème lorsqu'on l'a enfin surmonté.

Je conseillerai donc de compiler ce kernel, bien que je déteste ces
solutions à l'aveuglette qui tiennent plus du rite superstitieux que de
la bonne rationnalité qui devrait, ici, s'appliquer.

cordialement,
Bernard THOMAS
Le #8043151
triaxx a écrit :
Désolé, mais je ne possède pas cette carte et je ne l'ai encore moins
installé.


Cela ne fait rien. C'est la démarche qui m'intéresse.

lspci reconnait que ta carte est installé, donc le système la gère,


C'est bien des idées de ce genre qui m'intéresse. ;-)
Tout à fait d'accord avec toi.

mais aucun module n'est chargé. Essaye la commande : modprobe ipw2200


# modprobe ipw2200
FATAL: Error inserting ipw2200
(/lib/modules/2.6.12-12mdk-i686-up-4GB/kernel/3rdparty/ipw2200/ipw2200.ko.gz):
Invalid argument

Je suis donc planté à ce stade-là.
+ Il y a bien le fichier indiqué dans le message d'erreur.
- Je n'ai aucune idée de l'argument qui lui fait souci.
Google, mon grand ami en l'occasion, n'est pas très aidant alors qu'il a
des indices précieux.... Je cherche encore à la solution.
Si je trouve tout seul (ce dont je doute fortement) je note la solution
ici.

Ensuite, la command ifconfig -a


Ca c'est la suite. J'en rêve depuis un moment ;-)

Bon courage et bonne chance.


Merci de tes conseils. Je repars à la chasse dans Google...
Si tu es motivé pour suivre la même piste que moi, n'hésite pas à poser
d'autres questions....
Bernard
Bernard THOMAS
Le #8043141
>> Bonjour le groupe,
je viens de alt.fr.comp.reseaux.wifi où j'ai posé la même question en
vain. Les échanges m'ont juste permis de mieux formuler le problème.
Mandriva2006 en dual boot avec un XP
une carte wifi Intel Pro wireless 2200BG (qui fonctionne parfaitement
sous XP) et qui a fonctionné quelques temps sous linux. Puis s'est
arrêtée.


Pour ma part, j'ai eu moult problèmes avec le toshiba de mon fils ; en
fait, il y a un problème entre l'acpi et le wifi. Essaye de désactiver
l'acpi, le wifi devrait remarcher.




Perso, j'ai réussi à faire fonctionner les deux (wifi et acpi) avec le
kernel 2.6.15-rc4 ; j'ai essayé, il y a peu, d'installer un kernel plus
récent, mais les problèmes ont resurgi alors je suis revenu au kernel
précédent :(

Le problème vient peut-être d'un partage d'interuption mal géré... je ne
me souviens plus.

Moralité : on a tjrs tort de ne pas noter le mode de résolution d'un
problème lorsqu'on l'a enfin surmonté.

Je conseillerai donc de compiler ce kernel, bien que je déteste ces
solutions à l'aveuglette qui tiennent plus du rite superstitieux que de
la bonne rationnalité qui devrait, ici, s'appliquer.

cordialement,



B'jour,
Là c'est un Dell LatitudeD600.
Ta suggestion est intéressante. Elle pourrait expliquer pourquoi cela
marchait et que cela s'est arrêté sans que je puisse comprendre quelle
pouvait être la cause... L'ACPI se serait activé et aurait perturbé le
wifi. Posons cette hypothèse séduisante ; elle reste à vérifier par la
suite.
Petit problème : je ne sais pas désactiver l'ACPI. As-tu une idée ?

Je préférerais éviter de recompiler le noyau.
- je n'ai pas encore le niveau pour me lancer là dedans... avec le temps
d'exécution que je m'accorde.
- cela a marché, même fugitivement. Donc on doit pouvoir le refaire
marcher avec le même noyau. Je préférerais rester au niveau du driver.
C'est déjà assez pour moi actuellement :-
Avec tous mes remerciements pour ces suggestions, cordialement
Bernard
Bernard THOMAS
Le #8043131
triaxx a écrit :
Désolé, mais je ne possède pas cette carte et je ne l'ai encore moins
installé.
lspci reconnait que ta carte est installé, donc le système la gère, mais
aucun module n'est chargé. Essaye la commande : modprobe ipw2200 pour
charger le module qui va bien.
Ensuite, la command ifconfig -a permet d'afficher toutes les interfaces
réseaux reconnues par le système, même si elles ne sont pas encore
configurées. Si ta carte apparaît, tu devrais pouvoir la configurer via
les utilitaires Mandriva.

Bon courage et bonne chance.


je résume les informations techniques du message précédent:
# modprobe ipw2200
FATAL: Error inserting ipw2200
(/lib/modules/2.6.12-12mdk-i686-up-4GB/kernel/3rdparty/ipw2200/ipw2200.ko.gz):
Invalid argument

si je me penche sur modprobe, cela donne cela:
# modprobe -c | grep ipw2200
options ipw2200 associate=MonESSID-Id channel=6 mode=open hwcrypto=MaClé
alias usb:v0BC3p0001d*dc*dsc*dp*ic*isc*ip ipw
alias pci:v00008086d00001043sv000008086sd00000270lbc*sc*i* ipw2200
....etc... j'en saute un paquet qui ressemble beaucoup....
alias pci:v00008086d00004224sv*sd*bc*sc*i* ipw2200

Un peu touffu... Mais sûrement très instructif ?
Bernard
Frédéric Fauberteau
Le #8043111
Bernard THOMAS a écrit :
Petit problème : je ne sais pas désactiver l'ACPI. As-tu une idée ?


Alors il me semble qu'il faut passer l'option 'noacpi' au kernel lors du
démarrage ... Je suppose que tu utilises grub et donc ça se passe dans
le fichier /boot/grub/menu.lst (ou /etc/lilo.conf pour lilo).

La syntaxe de ces fichiers est assez claire et il est assez simple de
repérer les blocs qui constitue les informations pour charger UN
système. Il faut alors recopier un bloc (celui qui démarre le système
par défaut tant qu'à faire), et de rajouter à la fin de la ligne qui
correspond au chargement du noyau un noacpi (cette ligne contient un
vmlinuz ou quelque chose du genre). Il peut être judicieux de modifier
le nom du système de votre nouveau bloc en lui ajoutant à la fin noacpi
par exemple pour le reconnaître au démarrage ...

PS : si c'est lilo, une fois le fichier édité, il faut faire un appel à
la commande lilo pour mettre à jour le MBR.

Bon courage, en espèrant que ça résoude le problème, ou du moins, que ça
aide à avance :)
jc
Le #8043101
Bernard THOMAS wrote:
....
Petit problème : je ne sais pas désactiver l'ACPI. As-tu une idée ?

...
Bernard



Tu as une Mandrake ou Mandriva, donc tu as un Mandrake Control Center ou
équivalent. Tu rentres dedans:
->Système ->Activer ou désactiver les services systèmes
Désactives ACPI au démarrage et arrête le! Rien de plus simple.
Bernard THOMAS
Le #8043091
jc a écrit :
Bernard THOMAS wrote:
....
Petit problème : je ne sais pas désactiver l'ACPI. As-tu une idée ?

...
Bernard



Tu as une Mandrake ou Mandriva, donc tu as un Mandrake Control Center ou
équivalent. Tu rentres dedans:
->Système ->Activer ou désactiver les services systèmes
Désactives ACPI au démarrage et arrête le! Rien de plus simple.



Limpide ! Merci, c'est épatant.
Je fais l'essai dès que j'ai remis le système en état pour éviter de me
retrouver dans la même situation instable.
Bernard
Poster une réponse
Anonyme