debian et serial ata [long]

Le
Latreyte David
--Boundary-00=_MyBbBmKvjwaKAv1
Content-Type: text/plain;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable

Bonjour,
j'essai d'installer en ce moment une sarge sur un serveur Dell
express5800/110Eh. La bête possède une carte gigabyte et deux dis=
ques SATA.

Apparemment, le noyau 2.4.26 (en version smp ou pas) ne gère pas le SA=
TA et
mes disques durs sont utilisés en IDE ; résultat : l'ensemble fon=
ctionne (la
distribution est installée) mais très lentement.
J'ai donc tenté une installation du 2.6.8 (en version smp ou pas) et l=
à,
malheureusement, je me prend un kernel panic de derrière les fagots :

pivot_root : no such file or directory
/sbin/init:424 cannot open /dev/console :no such file
kernel panic :attempted to kill init

J'ai effectué quelques recherches et ai trouvé ceci :
"""I switched from 2.4.x to 2.6.6-smp on a Dell PowerEdge 750.
I encountered exactly the same problem. When investigating into it, I reali=
zed
that the initrd image of the new kernel now contained additional modules
ata_piix and sd_mod. Also, just before the kernel panic occured, the log
showed that a disk /dev/scsi/host1/bus0/target0/lun0 had been attached
although the system does not contain any SCSI disks. Just a few lines befor=
e
the kernel panic message there were lines like "ide0: I/O resource XXX not=

free".
So I assumed that the single harddisk had been attached as SCSI instead of =

IDE. Changing the initrd wasn't successful, so I eventually tried to change=

the root device in /boot/grub/menu.lst to /dev/sda1 and that helped. The on=
ly
confusing thing that remains is, that when started up the system has again=

mounted / on /dev/hda1 !??
So maybe try to change the lines starting with kernel in /boot/grub/menu.ls=
t
in a way that they contain root=/dev/sda1 instead of root=/dev/hdxy."""

Que pensez-vous de cette solution ? En existe-t-il de meilleure ? (je n'ai =
pas
eu le temps d'essayer ce soir, c'est remis à demain).

Merci poour toute réponse.

PS : si c'est bien le cas, merci Grub car les tests seront faciles à f=
aire à
l'aide du shell intégré.

PS : quel est le réel intérêt de smp ? Je pensais qu'il n'=
était utile que pour
les cartes multiprocesseurs.

--
Latreyte David http://www.gaule.org
Debian GNU/Linux
--

--Boundary-00=_MyBbBmKvjwaKAv1
Content-Type: text/html;
charset="utf-8"
Content-Transfer-Encoding: quoted-printable

<html><head><meta name="qrichtext" content="1" /></head><body style="=
font-size:10pt;font-family:Sans Serif">
<p>Bonjour,</p>
<p>j'essai d'installer en ce moment une sarge sur un serveur Dell express58=
00/110Eh. La bête possède une carte gigabyte et deux disques SATA=
.</p>
<p></p>
<p>Apparemment, le noyau 2.4.26 (en version smp ou pas) ne gère pas le=
SATA et mes disques durs sont utilisés en IDE ; résultat : l'ens=
emble fonctionne (la distribution est installée) mais très lentem=
ent.</p>
<p>J'ai donc tenté une installation du 2.6.8 (en version smp ou pas) e=
t là, malheureusement, je me prend un kernel panic de derrière le=
s fagots :</p>
<p></p>
<p>pivot_root : no such file or directory</p>
<p>/sbin/init:424 cannot open /dev/console :no such file</p>
<p> kernel panic :attempted to kill init</p>
<p></p>
<p>J'ai effectué quelques recherches et ai trouvé ceci :</p>
<p> &quot;&quot;&quot;I switched from 2.4.x to 2.6.6-smp on a Dell PowerEdg=
e 750.</p>
<p>I encountered exactly the same problem. When investigating into it, I re=
alized that the initrd image of the new kernel now contained additional mod=
ules ata_piix and sd_mod. Also, just before the kernel panic occured, the l=
og showed that a disk /dev/scsi/host1/bus0/target0/lun0 had been attached a=
lthough the system does not contain any SCSI disks. Just a few lines before=
the kernel panic message there were lines like &quot;ide0: I/O resource XX=
X not free&quot;.</p>
<p>So I assumed that the single harddisk had been attached as SCSI instead =
of IDE. Changing the initrd wasn't successful, so I eventually tried =
to change the root device in /boot/grub/menu.lst to /dev/sda1 and that help=
ed. The only confusing thing that remains is, that when started up the syst=
em has again mounted / on /dev/hda1 !??</p>
<p>So maybe try to change the lines starting with kernel in /boot/grub/menu=
.lst in a way that they contain root=/dev/sda1 instead of root=/dev/h=
dxy.&quot;&quot;&quot;</p>
<p></p>
<p>Que pensez-vous de cette solution ? En existe-t-il de meilleure ? (je n'=
ai pas eu le temps d'essayer ce soir, c'est remis à demain).</p>
<p></p>
<p>Merci poour toute réponse.</p>
<p></p>
<p>PS : si c'est bien le cas, merci Grub car les tests seront faciles =
faire à l'aide du shell intégré.</p>
<p></p>
<p>PS : quel est le réel intérêt de smp ? Je pensais qu'il n=
'était utile que pour les cartes multiprocesseurs.</p>
<p></p>
<p>-- </p>
<p>Latreyte David http://www.gaule.org</p>
<p>Debian GNU/Linux</p>
<p>--</p>
<p></p>
</body></html>
--Boundary-00=_MyBbBmKvjwaKAv1--


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
franck Molle
Le #9422011
Latreyte David wrote:
Bonjour,

j'essai d'installer en ce moment une sarge sur un serveur Dell
express5800/110Eh. La bête possède une carte gigabyte et deux disques SATA.

Apparemment, le noyau 2.4.26 (en version smp ou pas) ne gère pas le SATA
et mes disques durs sont utilisés en IDE ; résultat : l'ensemble
fonctionne (la distribution est installée) mais très lentement.


bienvenue au club :/ j'ai le meme pb


J'ai donc tenté une installation du 2.6.8 (en version smp ou pas) et là,
malheureusement, je me prend un kernel panic de derrière les fagots :



le 2.6 gere le sata comme du scsi donc avant de relancer ton serveur et
redemarrer sur ton 2.6 il te faut modifier fstab et relancer lilo avec
les bons parametres sachant que la partition / sera sur sda au prochain
redemarrage.

maintenant il existe la possibilité d'utiliser le cd de dell (voir mes
mails precedents) pour faire ton installation directement sur sda. Ce cd
possede un kernel 2.4 qui reconait le sata correctement car il a été
patché. J'essais d'ailleurs de comprendre comment ils ont fait mais avec
assez peu de succes je dois dire.

bye
--
*************************************************
* Franck MOLLE *
* Animateur de Secteur *
* Relais assistance Tice, Louviers-Vernon *
*************************************************


--
Pensez
Laurent CARON
Le #9421901
franck Molle wrote:

Latreyte David wrote:

Bonjour,

j'essai d'installer en ce moment une sarge sur un serveur Dell
express5800/110Eh. La bête possède une carte gigabyte et deux
disques SATA.

Apparemment, le noyau 2.4.26 (en version smp ou pas) ne gère pas le
SATA et mes disques durs sont utilisés en IDE ; résultat :
l'ensemble fonctionne (la distribution est installée) mais très
lentement.



bienvenue au club :/ j'ai le meme pb


J'ai donc tenté une installation du 2.6.8 (en version smp ou pas) et
là , malheureusement, je me prend un kernel panic de derrière les
fagots :



le 2.6 gere le sata comme du scsi donc avant de relancer ton serveur
et redemarrer sur ton 2.6 il te faut modifier fstab et relancer lilo
avec les bons parametres sachant que la partition / sera sur sda au
prochain redemarrage.

maintenant il existe la possibilité d'utiliser le cd de dell (voir
mes mails precedents) pour faire ton installation directement sur sda.
Ce cd possede un kernel 2.4 qui reconait le sata correctement car il a
été patché. J'essais d'ailleurs de comprendre comment ils ont fait
mais avec assez peu de succes je dois dire.



La lib-ata a été ajoutée


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Latreyte David
Le #9421711
Le Mercredi 13 Octobre 2004 00:00, franck Molle a écrit :
Latreyte David wrote:



Bonjour


le 2.6 gere le sata comme du scsi donc avant de relancer ton serveur et
redemarrer sur ton 2.6 il te faut modifier fstab et relancer lilo avec
les bons parametres sachant que la partition / sera sur sda au prochain
redemarrage.



c'est bien ça, tout fonctionne à merveille à présent.
Cela dit je me suis quand même fait avoir car, dans un premier temps, comme
test, j'ai juste modifié Grub à la ligne de commande. Résult at : le noyau a
bien été trouvé mais a persisté dans son idée de m onter / sur /dev/hdc1. J'ai
mis un quart d'heure à réaliser qu'il fallait aussi modifier /etc /fstab.

Merci pour les réponses.
Bye
--
Latreyte David http://www.gaule.org
Debian GNU/Linux
--
Poster une réponse
Anonyme