Erreur segmentation

Le
Tom Dupont
Bonjour,

Pendant ces vacances, j'ai essayé de synchroniser mon pda (Axim X5 sous
Pocketpc ) avec kde en utilisant synce et raki.

Mon pc fonctionne avec mandriva 2006 et kde 3.5. J'ai fait l'upgrade de 3.4
à 3.5 avec kiosk.

Je n'ai pas réussi à synchroniser kontact avec mon pda, ni à naviguer avec
konqueror dans le pda. Bien que la connection se faisait. En ligne de
commande, ça fonctionnait.

J'ai donc recherché des packages plus récents en rpm et tar. J'en ai
installés certains et d'autres avaient des problèmes de dépendances.

Quand j'en ai eu marre. J'ai voulu désinstallé synce.

Et maintenant, je ne suis plus capable d'installer ou de désinstaller le
moindre programme à base de rpm. rpmdrake se fige. En ligne avec
urpme -v, aprés le scan des listes des médias, il indique désinstallation
du package puis erreur segmentation.

J'ai appelé mon ami google. On parle de nettoyage et reconstruction de la
base de donnée.

rm -rf /var/lib/rpm*.* /var/lib/rpm/__db* /var/lib/rpmrebuilddb*.*
rpm -v --rebuilddb


Ok tout va bien

Je réessaie et rien ne change.

J'aimerai pouvoir récupérer mon système de packages rpm sans devoir tout
réinstaller.

Quelqu'un a-t-il un retour d'expérience pour m'aider à trouver une
solution ?

Est-il possible de générer le système de package ?


Merci

Tom
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
sansflotusspam
Le #7945171
Tom Dupont wrote:

Bonjour,

Pendant ces vacances, j'ai essayé de synchroniser mon pda (Axim X5 sous
Pocketpc ) avec kde en utilisant synce et raki.

Mon pc fonctionne avec mandriva 2006 et kde 3.5. J'ai fait l'upgrade de
3.4 à 3.5 avec kiosk.

Je n'ai pas réussi à synchroniser kontact avec mon pda, ni à naviguer avec
konqueror dans le pda. Bien que la connection se faisait. En ligne de
commande, ça fonctionnait.

J'ai donc recherché des packages plus récents en rpm et tar. J'en ai
installés certains et d'autres avaient des problèmes de dépendances.

Quand j'en ai eu marre. J'ai voulu désinstallé synce.

Et maintenant, je ne suis plus capable d'installer ou de désinstaller le
moindre programme à base de rpm. rpmdrake se fige. En ligne avec
urpme -v, aprés le scan des listes des médias, il indique désinstallation
du package puis erreur segmentation.

J'ai appelé mon ami google. On parle de nettoyage et reconstruction de la
base de donnée.

rm -rf /var/lib/rpm*.* /var/lib/rpm/__db* /var/lib/rpmrebuilddb*.*
rpm -v --rebuilddb


Ok tout va bien

Je réessaie et rien ne change.

J'aimerai pouvoir récupérer mon système de packages rpm sans devoir tout
réinstaller.

Quelqu'un a-t-il un retour d'expérience pour m'aider à trouver une
solution ?

Est-il possible de générer le système de package ?


Merci

Tom



avec kde, il faut utiliser kpilot ...
kpp
Le #7945141
Tom Dupont wrote:

Bonjour,




Et maintenant, je ne suis plus capable d'installer ou de désinstaller le
moindre programme à base de rpm. rpmdrake se fige. En ligne avec
urpme -v, aprés le scan des listes des médias, il indique désinstallation
du package puis erreur segmentation.



Quelqu'un a-t-il un retour d'expérience pour m'aider à trouver une
solution ?



Bonjour

Ouf, je croyais être le seul à avoir ce problème.

J'ai réussi a m'en sortir plusieurs fois, sans vraiment comprendre
ce qui se passe :

1 ) Extinction du PC ( dans les règles )
2 ) Allumage . et tout de suite lancement du "gestionnaire de média
logiciel" par le menu
( surtout pas un des autres modules, ni la gestion des médias par menu du
module d'installation )
3 ) mise a jour des média 1 par 1 pour vérifier si tous les médias sont bien
accessibles
3 bis ) détruire éventuellement un média inaccessible
4 ) extinction du PC ( sans rien faire d'autre )
5 ) allumage ... et en général ça remarche

Je ne sais ni pourquoi, ni comment rpmdrake bloque, mais aprés avoir
vraiment beaucoup transpiré sur le sujet, c'est la solution que j'ai
trouvée, et que j'ai du renouveler au moins 2 fois cette année.

nota pistes supplémentaires :
1) J'ai un répertoire avec des rpm que je récupère sur internet et que je
reconnais en tant que média . dans ce répertoire j'ai du effacer 2 versions
de "ksudoku" , qui me faisait planter la base à chaque fois que je les
sélectionnais !
2) N'utiliser qu'un seul module de rpmdrake a la fois.

En espérant que cela marchera aussi pour toi

cordialement
kpp
Tom Dupont
Le #7945131
alut,

Pour ce qui est de redémarrer, faire une mise à jour et redémarrer, pour moi
c'est trop tard :-(

Par contre, je crois bien que le problème doit se situer au niveau d'une
dépendance, d'un mélange de packages prévus pour tel ou tels distributions.
Ma soupe pour essayer d'utiliser kde avec mon pda, m'a amené à tenter
d'installer des packages ne venant pas exclusivement de Mandriva.

Je ne savais pas que cela représentait un risque (et trouve personnellement
nulle qu'il faille resté avec les packages de sa distribution, merci les
monopoles de fait !!!)

Pour l'instant, le but est de tenter de redémarer la database rpm. On
cherche, on cherche, .....

A+ dans le prochain épisode.
Tom

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

kpp wrote:

Tom Dupont wrote:

Bonjour,




Et maintenant, je ne suis plus capable d'installer ou de désinstaller le
moindre programme à base de rpm. rpmdrake se fige. En ligne avec
urpme -v, aprés le scan des listes des médias, il indique désinstallation
du package puis erreur segmentation.



Quelqu'un a-t-il un retour d'expérience pour m'aider à trouver une
solution ?



Bonjour

Ouf, je croyais être le seul à avoir ce problème.

J'ai réussi a m'en sortir plusieurs fois, sans vraiment comprendre
ce qui se passe :

1 ) Extinction du PC ( dans les règles )
2 ) Allumage . et tout de suite lancement du "gestionnaire de média
logiciel" par le menu
( surtout pas un des autres modules, ni la gestion des médias par menu du
module d'installation )
3 ) mise a jour des média 1 par 1 pour vérifier si tous les médias sont
bien accessibles
3 bis ) détruire éventuellement un média inaccessible
4 ) extinction du PC ( sans rien faire d'autre )
5 ) allumage ... et en général ça remarche

Je ne sais ni pourquoi, ni comment rpmdrake bloque, mais aprés avoir
vraiment beaucoup transpiré sur le sujet, c'est la solution que j'ai
trouvée, et que j'ai du renouveler au moins 2 fois cette année.

nota pistes supplémentaires :
1) J'ai un répertoire avec des rpm que je récupère sur internet et que je
reconnais en tant que média . dans ce répertoire j'ai du effacer 2
versions de "ksudoku" , qui me faisait planter la base à chaque fois que
je les sélectionnais !
2) N'utiliser qu'un seul module de rpmdrake a la fois.

En espérant que cela marchera aussi pour toi

cordialement
kpp


Poster une réponse
Anonyme