ffmpeg ? script mp4

Le
ptilou
Slt,

Je fais çÍ  :
[philippe@fedora Vidéos]$ vi test-ffmpeg.sh
[philippe@fedora Vidéos]$ ./test-ffmpeg.sh
ffmpeg version 4.4-static https://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2021 the FFmpeg developers
built with gcc 8 (Debian 8.3.0-6)
configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disable-indev=sndio --disable-outdev=sndio --cc=gcc --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gmp --enable-libgme --enable-gray --enable-libaom --enable-libfribidi --enable-libass --enable-libvmaf --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librubberband --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libdav1d --enable-libxvid --enable-libzvbi --enable-libzimg
libavutil 56. 70.100 / 56. 70.100
libavcodec 58.134.100 / 58.134.100
libavformat 58. 76.100 / 58. 76.100
libavdevice 58. 13.100 / 58. 13.100
libavfilter 7.110.100 / 7.110.100
libswscale 5. 9.100 / 5. 9.100
libswresample 3. 9.100 / 3. 9.100
libpostproc 55. 9.100 / 55. 9.100
*.MP4: No such file or directory
[philippe@fedora Vidéos]$

Pour çÍ  comme script :
for f in *.MP4
do ./ffmpeg -i "$f" -r 25 "$f"_[%0d].png
done

ALors que quand je tape çÍ  :
for f in *.AVI /
do ./ffmpeg -i "$f" -r 25 "$f"_[%0d].png
done

J'ai mes film en images, et donc je suppose qu'il manque juste le codec, donc ffmpeg, comme il en portable, faut telecharger et compiler, chercher les depot build ?
SUr F34 tous Í  jour meme grayscale

Merci

--
ptilou
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
ptilou
Le #26579605
Le samedi 23 octobre 2021 Í  18:29:23 UTC+2, ptilou a écrit :
Slt,
Je fais çÍ  :
[ Vidéos]$ vi test-ffmpeg.sh
[ Vidéos]$ ./test-ffmpeg.sh
ffmpeg version 4.4-static https://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2021 the FFmpeg developers
built with gcc 8 (Debian 8.3.0-6)
configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disable-indev=sndio --disable-outdev=sndio --cc=gcc --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gmp --enable-libgme --enable-gray --enable-libaom --enable-libfribidi --enable-libass --enable-libvmaf --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librubberband --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libdav1d --enable-libxvid --enable-libzvbi --enable-libzimg
libavutil 56. 70.100 / 56. 70.100
libavcodec 58.134.100 / 58.134.100
libavformat 58. 76.100 / 58. 76.100
libavdevice 58. 13.100 / 58. 13.100
libavfilter 7.110.100 / 7.110.100
libswscale 5. 9.100 / 5. 9.100
libswresample 3. 9.100 / 3. 9.100
libpostproc 55. 9.100 / 55. 9.100
*.MP4: No such file or directory
[ Vidéos]$
Pour çÍ  comme script :
for f in *.MP4
do ./ffmpeg -i "$f" -r 25 "$f"_[%0d].png
done
ALors que quand je tape çÍ  :
for f in *.AVI /
do ./ffmpeg -i "$f" -r 25 "$f"_[%0d].png
done
J'ai mes film en images, et donc je suppose qu'il manque juste le codec, donc ffmpeg, comme il en portable, faut telecharger et compiler, chercher les depot build ?
SUr F34 tous Í  jour meme grayscale ...

Donc j’ai tapé en direct la commande ffmpeg et elle fonctionne !
A mon avis contrairement Í  mon explication bitloker c’est pas un bug, mais l’action de quelqu’un du mauvais cÍ´té de la force binaire …
Do donc avant plus de trois messages par jours, alors que maintenant pas tous les jours, une sorte de nationalisation !
Merci
--
ptilou
ptilou
Le #26579668
Le dimanche 24 octobre 2021 Í  19:38:13 UTC+2, ptilou a écrit :
Le samedi 23 octobre 2021 Í  18:29:23 UTC+2, ptilou a écrit :
Slt,
Je fais çÍ  :
[ Vidéos]$ vi test-ffmpeg.sh
[ Vidéos]$ ./test-ffmpeg.sh
ffmpeg version 4.4-static https://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2021 the FFmpeg developers
built with gcc 8 (Debian 8.3.0-6)
configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disable-indev=sndio --disable-outdev=sndio --cc=gcc --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gmp --enable-libgme --enable-gray --enable-libaom --enable-libfribidi --enable-libass --enable-libvmaf --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librubberband --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libdav1d --enable-libxvid --enable-libzvbi --enable-libzimg
libavutil 56. 70.100 / 56. 70.100
libavcodec 58.134.100 / 58.134.100
libavformat 58. 76.100 / 58. 76.100
libavdevice 58. 13.100 / 58. 13.100
libavfilter 7.110.100 / 7.110.100
libswscale 5. 9.100 / 5. 9.100
libswresample 3. 9.100 / 3. 9.100
libpostproc 55. 9.100 / 55. 9.100
*.MP4: No such file or directory
[ Vidéos]$
Pour çÍ  comme script :
for f in *.MP4
do ./ffmpeg -i "$f" -r 25 "$f"_[%0d].png
done
ALors que quand je tape çÍ  :
for f in *.AVI /
do ./ffmpeg -i "$f" -r 25 "$f"_[%0d].png
done
J'ai mes film en images, et donc je suppose qu'il manque juste le codec, donc ffmpeg, comme il en portable, faut telecharger et compiler, chercher les depot build ?
SUr F34 tous Í  jour meme grayscale ...

Donc j’ai tapé en direct la commande ffmpeg et elle fonctionne !
A mon avis contrairement Í  mon explication bitloker c’est pas un bug, mais l’action de quelqu’un du mauvais cÍ´té de la force binaire …
Do donc avant plus de trois messages par jours, alors que maintenant pas tous les jours, une sorte de nationalisation !


for f in *.MP4
do ./ffmpeg -i "$f" -r 25 "$f"_[%0d].png
done

Finalement comme ça cela fonctionne, le bluthoot peut-etre ?
Bon dés corseS qui n’ont pas compris que les locau ne peuvent faire vivre ?
D’ailleurs ce soir un fonctionnaire nous a déclarer ses revenu …
Merci
--
ptilou
Poster une réponse
Anonyme