Formules de calcul de période d'essai

Le
seb
Bonjour à tous,

J'essaie de mettre en place une formule qui me calcule automatiquement les
périodes d'essai.

Je n'y arrive et systématiquement, j'ai des "erreurs" de formules

Quelqu'un pourrait-il m'aider ?

Ma formule donne à peu près ça mais c'est faux
=SI(ou(C2="C. de
prof.";C2="CDD";(G2-F2)/7);si(D2="Employé(e);1);si(D2="Agent
maîtrise";2);si(ou(D2="Cadre";D2="Négociateur";3);0)

L'idée :
-> si CDD, apprenti, contrat de qualif (tout sauf CDI) alors calcul en
jours d'essai date de fin - date d'entrée (si moins de 6 mois de contrat
sinon 1 mois comme un Employé(e)). Idéalement, quand calcul en jours (- de 6
mois) le résultat trouvé (en colonne H) doit "compléter" la colonne I mais en
éliminant les 2 jours de week-end. Exemple : si 14 jours d'essai à partir du
01/02/2006 alors date de fin le 20/02/2006 au soir et non pas le 14/02/06

-> Plus simple (?) : Si CDI alors selon statut :
Employé(e) : 1 mois, Agent maîtrise : 2 mois, Cadre ou Négociateur : 3
mois.

Est-ce possible ?? Ci-joint un tableau récapitulatif de ce que j'ai à
l'écran
http://cjoint.com/?cjlBHYj7jr

Merci bcp par avance !

Cordialement, SEb
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
JpPradier
Le #3405501
Bonjour seb

Essaye cette formule :

=SI(C2="CDI";SI(D2="Employé(e)";1;SI(D2="Agent maîtrise";2;3));(G2-F2)/7)

Pour le décompte des jours ouvrables, tu peux utiliser :
=NB.JOURS.OUVRES(DateDebut;DateFin;JoursFeries)
Cette fonction est disponible avec la macro complémentaire Utilitaires d'analyse.

j-p
seb
Le #3404931
Bonjour et merci pour votre réponse...

La formule fonctionne sauf pour les CDD avec période en jours ouvrés...
Dois-je insérer une colonne supplémentaire qui prendrait en compte seulement
les CDD et une autre que les CDI ??? ça semble plus simple mais du coup, je
m'emmele...

Merci par avance pour votre aide

Cdlt, Seb
JpPradier
Le #3404901
Re

Pour les CDD, j'ai repris ta formule (G2-F2)/7 . Qu'est-ce que tu veux avoir à la place ?
En remplacant par Nb.JOURS.OUVRES(F2;G2;JoursFeries) ca devrait le faire.
JourFeries est une plage nommée ou tu mets les dates fériées par ton entreprise.

j-p
Poster une réponse
Anonyme