[gentoo-user-fr] [Wifi+VPN] Probleme lors de l'envoi de fichiers

Le
youshe zifeng
Bonjour,

Depuis pas mal de temps je remarque pas mal de problèmes lors de
l'envoi de fichiers par wifi en passant par le vpn de ma fac. Voici
quelques renseignements en vrac.

- Client VPN cisco pour linux récupéré sur le site de ma fac
- Problème rencontré avec plusieurs protocoles (http, ssh)
- Quelques problèmes sur certains sites avec les cookies (impossible
de se déconnecter de google autrement qu'en supprimant les cookies
manuellement sous firefox quelque soit la version)
- Souvent des problèmes d'envoi de mails avec un serveur tournant sour
horde (free ou webmail de ma fac)
- Pas de problème en liaison filière sans VPN
- Pas de problème sous un autre OS (win) en utilisant wifi+VPN
- Pas de problème lors de la réception de fichiers (ssh, http)
- D'autres personnes utilisant le vpn sous ubuntu n'ont pas de problème
- Tout ce qui est http passe par un proxy, ssh non bloqué par le VPN
(ce qui semblerait mettre le proxy hors de cause)
- je n'ai pas fait de tests sans être dans le réseau VPN (pas de borne
disponible pour)
- je n'ai pas testé d'autres distributions (deb ou autres)
- Ordinateur : tecra A8 de chez toshiba avec une carte wifi (et
drivers) intel description sur le site de toshiba pour Tecra A8-159.
- L'envoi de fichiers fonctionne de rares fois en scp

Je pense que le problème vient soit du driver intel pour ma carte
wifi, soit d'une option mal choisie dans le noyau, soit du client VPN.
Est ce que les symptomes diraient quelque chose à quelqu'un ? Où
puis-je chercher ?

Merci

Fred

--
gentoo-user-fr@gentoo.org mailing list
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Aurélien Francillon
Le #7785191
On Thursday 07 December 2006 15:29, youshe zifeng wrote:
Bonjour,

Depuis pas mal de temps je remarque pas mal de problèmes lors de
l'envoi de fichiers par wifi en passant par le vpn de ma fac. Voici
quelques renseignements en vrac.

- Client VPN cisco pour linux récupéré sur le site de ma fac



Est ce que tu l'a installé avec l'ebuild "net-misc/cisco-vpnclient-3des" ?
il fixe des problèmes pour certaines versions ...
en plus ca n'a pas l'air très bien fait et ca te charge un module binaire dans
le noyau ... et j'avais deja eu de s problemes il y a quelques mois avec ...

tu peux aussi essayer de te connecter avec net-misc/vpnc je crois que c'est a
peu près compatible avec le vpn cisco
j'ai quelques notes la dessus:
http://www.inrialpes.fr/planete/people/francill/vpnc_inria.txt

mais le manque de fiabilité générale a eu raison de moi, et ca fait un moment
que je n'ai pas essayé ...

Aurélien

--
mailing list
youshe zifeng
Le #7785181
> Est ce que tu l'a installé avec l'ebuild "net-misc/cisco-vpnclient-3des" ?
il fixe des problèmes pour certaines versions ...



Non, je n'avais pas la version de portage. Je viens d'essayer avec
cette version mais j'ai toujours le même problème

tu peux aussi essayer de te connecter avec net-misc/vpnc je crois que c'est a
peu près compatible avec le vpn cisco

j'ai quelques notes la dessus:
http://www.inrialpes.fr/planete/people/francill/vpnc_inria.txt



Donc testé mais problème lors du lancement, après avoir entré mon mot
de passe :
vpnc: can't open /dev/net/tun, check that it is either device char 10
200 or (with DevFS) a symlink to ../misc/net/tun (not misc/net/tun):
No such device
vpnc: can't initialise tunnel interface: No such device
J'ai donc listé /dev/net/ et j'obtient :
crw-r----- 1 root root 10, 200 Dec 7 18:15 tun

Qu'est ce que cela veut dire ?

mais le manque de fiabilité générale a eu raison de moi, et ca fait un moment
que je n'ai pas essayé ...

Aurélien



Merci pour cette réponse qui a fait avancer un peu le problème.

Fred

--
mailing list
Aurélien Francillon
Le #7785171
On Thursday 07 December 2006 18:26, youshe zifeng wrote:
> Est ce que tu l'a installé avec l'ebuild "net-misc/cisco-vpnclient-3des"
> ? il fixe des problèmes pour certaines versions ...

Non, je n'avais pas la version de portage. Je viens d'essayer avec
cette version mais j'ai toujours le même problème



au moins c'est installé 'proprement' maintenant ;)

> tu peux aussi essayer de te connecter avec net-misc/vpnc je crois que
> c'est a peu près compatible avec le vpn cisco
>
> j'ai quelques notes la dessus:
> http://www.inrialpes.fr/planete/people/francill/vpnc_inria.txt

Donc testé mais problème lors du lancement, après avoir entré mon mot
de passe :
vpnc: can't open /dev/net/tun, check that it is either device char 10
200 or (with DevFS) a symlink to ../misc/net/tun (not misc/net/tun):
No such device
vpnc: can't initialise tunnel interface: No such device
J'ai donc listé /dev/net/ et j'obtient :
crw-r----- 1 root root 10, 200 Dec 7 18:15 tun

Qu'est ce que cela veut dire ?




ca a l'air ok mais le script crée le fichier /dev/net/tun s'il n'est pas la...
par contre il ne compile pas le driver tun pour toi ;)
est ce que tu a les bons modules dans ton noyau ?
zcat /proc/config.gz| grep TUN
doit t'afficher
CONFIG_TUN=y ou m
si c'est m il faut un coup de modprobe si c'est commenté ou "n" il faut
recompiler le noyau avec le support "CONFIG_TUN" "Universal TUN/TAP device
driver support" si c'est y le problème est ailleurs ...
voir :
http://www.gentoo.org/doc/en/draft/vpnc-howto.xml#doc_chap2

Aurélien


--
mailing list
Poster une réponse
Anonyme