Gros problème de boot

Le
AlphaZeta
Bonsoir,

J'ai un double boot XP/Mandriva 2006 géré par Lilo, une partition Windows
NTFS c: (hda1), une partition commune FAT32 d: (hda5), et une partition
Linux ext3 (hda6) et swap (hda7).
Voici mon problème suivant : au démarrage de l'ordinateur (portable), le
menu pour choisir l'OS s'affiche
puis, si XP est choisi, ça redémarre quelques secondes après l'apparition de
la page d'accueil (message furtif du genre "unmountable disk volume") et si
c'est Linux, tout se bloque avec le message :

ide : failed opcode was : unknown
hda : task_out_intr : status=0x51 {DriveReady SeekComplete Error}
hda : task_out_intr : error=0x10 {SectorIdNotFound}, LBAsect4239203,
high=8, low!475, sector4239203

J'ai cru comprendre que c'est le secteur de démarrage qui est en cause.
Faut-il donc réparer Lilo ?

J'ai alors utilisé la fonction "rescue" en bootant sur le CD d'installation
de Mandriva. J'ai choisi l'option "Re-install Boot Loader" et j'ai le
message suivant :

Installing driver SIS 5513 (for "Silicon Integrated Systems [SIS]|5513
[IDE]")
Can't find SIS5513.ko in archive
Can't find module SIS 5513
failed
Please wait, trying to find your root device

Et j'ai attendu très longtemps mais rien d'autre n'est apparu.

J'ajoute que j'ai aussi utilisé le CD bootable UBCD constitué d'outils
divers et variés mais j'ai peur de faire des bêtises et je n'arrive pas à
avoir un
diagnostic qui me paraît clair. Je vous livre en vrac les divers messages et
informations que j'ai pu avoir et qui me semblent intéressants :

Mes partitions :
MBR Master Boot Record
Pri Unused
Pri 1 Windows NT NTFS
Pri 2 Extended
Log Windows FAT-32
Ext Extended
Log Linux ext2fs
Ext Extended

Ranish Partition Manager me dit "Boot sector doesn't have valid information"
à propos de la partition FAT32 et FIPS me dit "Checking root sector
Partition table inconsistency".

Un logiciel de vérification de partitions m'indique :
"sectors counted : 156 301 488
defective sectors info : location
6 855 912
11 940 390
148 813 938"


Bref, je m'en remets à vos lumières. J'ai l'impression que cela tourne
autour de la table d'allocation des fichiers ou du secteur d'amorçage ou
quelque chose du genre. Je n'y connais pas grand chose.
Que puis-je faire ? Je commence à désespérer !

Merci d'avance.
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
moi-même
Le #8042711
> Bref, je m'en remets à vos lumières. J'ai l'impression que cela tourne
autour de la table d'allocation des fichiers ou du secteur d'amorçage ou
quelque chose du genre. Je n'y connais pas grand chose....
Que puis-je faire ? Je commence à désespérer !

Merci d'avance.



j'ai eu le même genre de problème.
Résolu en mettant le DVD 1 de Mandriva 2006 et en faisant une "réinstall"
sans rien modifier, sans ajouter de paquetage, uniquement en répondant oui
pour charger le secteur de démarrage.

A essayer avec précautions pour les données.

Amicalement
C Hiebel
AlphaZeta
Le #8042611
"moi-même" 45269fc9$0$23503$

j'ai eu le même genre de problème.
Résolu en mettant le DVD 1 de Mandriva 2006 et en faisant une "réinstall"
sans rien modifier, sans ajouter de paquetage, uniquement en répondant oui
pour charger le secteur de démarrage.

A essayer avec précautions pour les données.



Merci mais malheureusement, juste après la détection des cartes PMCIA et des
périphériques de stockage de masse USB, le disque dur n'arrête pas de
tourner et l'installation en reste là...
Poster une réponse
Anonyme