IIS 6 et l'asp = erreur 404

Le
Wardead
Bonjour a tous,

je fais mes premieres armes sur un superbe windows 2003 et son non
moins superbe IIS 6

mais j'ai un petit souci :(

j'ai bien vu qu'il faut autoriser les extensions qu'on souhaite
utiliser sur ses sites car elles ne sont pas activées par defaut.

mais meme en ayant activé les extensions ASP
le mechant IIS me fait une erreur 404 quand j'essai de taper une de mes
pages en ASP :(

est ce que j'ai oublié un truc quelque part?

amicalement
Wardead

--
Ceci est une signature automatique de MesNews.
Site : http://www.mesnews.net
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
jbongran
Le #11484771
Wardead wrote:
Bonjour a tous,

je fais mes premieres armes sur un superbe windows 2003 et son non
moins superbe IIS 6

mais j'ai un petit souci :(

j'ai bien vu qu'il faut autoriser les extensions qu'on souhaite
utiliser sur ses sites car elles ne sont pas activées par defaut.

mais meme en ayant activé les extensions ASP
le mechant IIS me fait une erreur 404 quand j'essai de taper une de
mes pages en ASP :(

est ce que j'ai oublié un truc quelque part?

amicalement
Wardead



Un 404, c'est une page introuvable, eh ben non, pas toujours ;-), voir cette
page:
http://www.microsoft.com/resources/documentation/iis/6/all/proddocs/en-us/cerr_enablingcustom.mspx
Essaie de creer une page test.html et de l'afficher via son url (genre
http://localhost/test/test.html).
Si c'est Ok renommer cette page en test.asp et inclure après le tag <body>
un bout de code simple, par exemple Afficher via son url (genre http://localhost/test/test.asp)
Si c'est pas bon, vérifier si ce n'est pas une erreur 404.2 ou 404.3 en
regardant dans le log de iis.
Ne pas hésiter non plus si il est fait usage d'IE en tant que navigateur, de
décocher l'option "afficher des message d'erreurs http simplifiés"
Wardead
Le #11484751
Après mure réflexion, jbongran a écrit :
Wardead wrote:

Un 404, c'est une page introuvable, eh ben non, pas toujours ;-), voir cette
page:
http://www.microsoft.com/resources/documentation/iis/6/all/proddocs/en-us/cerr_enablingcustom.mspx
Essaie de creer une page test.html et de l'afficher via son url (genre
http://localhost/test/test.html).



plop ca c est fait ca marche,


Si c'est Ok renommer cette page en test.asp et inclure après le tag <body> un
bout de code simple, par exemple Afficher via son url (genre http://localhost/test/test.asp)



c est fait et ce n'est pas bon :(

Si c'est pas bon, vérifier si ce n'est pas une erreur 404.2 ou 404.3 en
regardant dans le log de iis.



ce sont des 404.2 a priori

Ne pas hésiter non plus si il est fait usage d'IE en tant que navigateur, de
décocher l'option "afficher des message d'erreurs http simplifiés"



fait aussi ;)

merci de ton aide

Wardead

P.S. ca commence a me saouler ce truc :( maintenant il me met "service
unavailable" meme pour un htm :(

ca a l'air vachement sympa ce qu'ils ont changés dans cette version par
rapport a l'ancienne, mais si je dois galerer x heures pour mettre un
site en route ca va pas le faire, je sens que je vais garder mes 2000
:(

--
Ceci est une signature automatique de MesNews.
Site : http://www.mesnews.net
Wardead
Le #11484731
Wardead vient de nous annoncer :
Après mure réflexion, jbongran a écrit :
Wardead wrote:

Un 404, c'est une page introuvable, eh ben non, pas toujours ;-), voir
cette page:
http://www.microsoft.com/resources/documentation/iis/6/all/proddocs/en-us/cerr_enablingcustom.mspx
Essaie de creer une page test.html et de l'afficher via son url (genre
http://localhost/test/test.html).



plop ca c est fait ca marche,


Si c'est Ok renommer cette page en test.asp et inclure après le tag <body>
un bout de code simple, par exemple Afficher via son url (genre http://localhost/test/test.asp)



c est fait et ce n'est pas bon :(

Si c'est pas bon, vérifier si ce n'est pas une erreur 404.2 ou 404.3 en
regardant dans le log de iis.



ce sont des 404.2 a priori

Ne pas hésiter non plus si il est fait usage d'IE en tant que navigateur,
de décocher l'option "afficher des message d'erreurs http simplifiés"



fait aussi ;)

merci de ton aide

Wardead

P.S. ca commence a me saouler ce truc :( maintenant il me met "service
unavailable" meme pour un htm :(

ca a l'air vachement sympa ce qu'ils ont changés dans cette version par
rapport a l'ancienne, mais si je dois galerer x heures pour mettre un site en
route ca va pas le faire, je sens que je vais garder mes 2000 :(



bon en fait je me repond a moi meme :)

j'avais trop bidouillé, le iis ne s'y retrouvais plus dans les
extensions, c etait marqué activé alors que non...
j'ai reinstallé le IIS et c est parti :)

@+ et merci

Wardead

--
Ceci est une signature automatique de MesNews.
Site : http://www.mesnews.net
jbongran
Le #11484721
Wardead wrote:
Wardead vient de nous annoncer :
Après mure réflexion, jbongran a écrit :
Wardead wrote:

Un 404, c'est une page introuvable, eh ben non, pas toujours ;-),
voir cette page:
http://www.microsoft.com/resources/documentation/iis/6/all/proddocs/en-us/cerr_enablingcustom.mspx
Essaie de creer une page test.html et de l'afficher via son url
(genre http://localhost/test/test.html).



plop ca c est fait ca marche,


Si c'est Ok renommer cette page en test.asp et inclure après le tag
<body> un bout de code simple, par exemple <%Response.Write "Texte
ASP%> Afficher via son url (genre http://localhost/test/test.asp)



c est fait et ce n'est pas bon :(

Si c'est pas bon, vérifier si ce n'est pas une erreur 404.2 ou
404.3 en regardant dans le log de iis.



ce sont des 404.2 a priori

Ne pas hésiter non plus si il est fait usage d'IE en tant que
navigateur, de décocher l'option "afficher des message d'erreurs
http simplifiés"



fait aussi ;)

merci de ton aide

Wardead

P.S. ca commence a me saouler ce truc :( maintenant il me met
"service unavailable" meme pour un htm :(

ca a l'air vachement sympa ce qu'ils ont changés dans cette version
par rapport a l'ancienne, mais si je dois galerer x heures pour
mettre un site en route ca va pas le faire, je sens que je vais
garder mes 2000 :(



bon en fait je me repond a moi meme :)

j'avais trop bidouillé, le iis ne s'y retrouvais plus dans les
extensions, c etait marqué activé alors que non...
j'ai reinstallé le IIS et c est parti :)

@+ et merci

Wardead



Comme quoi, avec un peu de ténacité ;-)
De quoi revoir ton jugement de Windows 2003 et de IIS 6.0
Wardead
Le #11484671
jbongran a présenté l'énoncé suivant :

Comme quoi, avec un peu de ténacité ;-)



ben le probleme est que j'ai ete un poil trop tenace en fait ;)
et que j'ai un peu perturbé le soft en bricolant partout.


De quoi revoir ton jugement de Windows 2003 et de IIS 6.0



yep, c est vrai ca marche pas trpo mal, a voir a l'usage :)

amicalement
WArdead

--
Ceci est une signature automatique de MesNews.
Site : http://www.mesnews.net
Poster une réponse
Anonyme