Installation de vuescan sous 2006

Le
jide
Bonjour, avec mes scanners pas reconnus, j'utilisais ,sur ma 9.2 ,vuescan
, qui marche tres bien. Je recidive avec la 2006 et.. la cata!
Telechargement sans pb, decompression avec ARK , et j'ai , entre autres,
un magnifique executable ( avec la petite roue dentee ) qui refuse
obstinement de s'executer. Pourtant , dans "proprietes" c'est bien un
executable! Si j'insiste ,le systeme me demande avec quel logiciel je veux
l'ouvrir..
Tout essaye, deplacer les dossiers, recopier les fichiers depuis la 9.2,
rien a faire et je n'ai plus de scanner! Une idee? Merci d'avance
J.D.
  • Partager ce contenu :
Vos réponses Page 1 / 2
Trier par : date / pertinence
Jacques Pronchery
Le #8051001
jide a écrit :
Bonjour, avec mes scanners pas reconnus, j'utilisais ,sur ma 9.2 ,vuescan
, qui marche tres bien. Je recidive avec la 2006 et.. la cata!
Telechargement sans pb, decompression avec ARK , et j'ai , entre autres,
un magnifique executable ( avec la petite roue dentee )... qui refuse
obstinement de s'executer. Pourtant , dans "proprietes" c'est bien un
executable! Si j'insiste ,le systeme me demande avec quel logiciel je veux
l'ouvrir..
Tout essaye, deplacer les dossiers, recopier les fichiers depuis la 9.2,
rien a faire et je n'ai plus de scanner! Une idee? Merci d'avance
J.D.



Bonjour,

Essaie de le lancer dans une console, il te dira peut-être
pourquoi il ne marche pas.

Jacques.
sansflotusspam
Le #8050991
jide a écrit :

Bonjour, avec mes scanners pas reconnus, j'utilisais ,sur ma 9.2 ,vuescan
, qui marche tres bien. Je recidive avec la 2006 et.. la cata!
Telechargement sans pb, decompression avec ARK , et j'ai , entre autres,
un magnifique executable ( avec la petite roue dentee )... qui refuse
obstinement de s'executer. Pourtant , dans "proprietes" c'est bien un
executable! Si j'insiste ,le systeme me demande avec quel logiciel je veux
l'ouvrir..
Tout essaye, deplacer les dossiers, recopier les fichiers depuis la 9.2,
rien a faire et je n'ai plus de scanner! Une idee? Merci d'avance
J.D.



quelle marque et quel type de scanner (et interface : scsi, usb, parallèle)?
il y en a vraiment très peu qui ne sont pas gérables ...
pistes possibles :
les bons droits (rwx rwx r-x) sur le binaire, les devices, les fichiers de
conf, etc
l'appartenance aux groupes "scanner" "usb", etc
un détail : avec les noyaux 2.6, il ne faut plus charger le module "scanner"
A+
jide
Le #8050971
Le Wed, 22 Feb 2006 11:09:38 +0100, sansflotusspam a écrit :

jide a écrit :

Bonjour, avec mes scanners pas reconnus, j'utilisais ,sur ma 9.2 ,vuescan
, qui marche tres bien. Je recidive avec la 2006 et.. la cata!
Telechargement sans pb, decompression avec ARK , et j'ai , entre autres,
un magnifique executable ( avec la petite roue dentee )... qui refuse
obstinement de s'executer. Pourtant , dans "proprietes" c'est bien un
executable! Si j'insiste ,le systeme me demande avec quel logiciel je veux
l'ouvrir..
Tout essaye, deplacer les dossiers, recopier les fichiers depuis la 9.2,
rien a faire et je n'ai plus de scanner! Une idee? Merci d'avance
J.D.



quelle marque et quel type de scanner (et interface : scsi, usb, parallèle)?
il y en a vraiment très peu qui ne sont pas gérables ...
pistes possibles :
les bons droits (rwx rwx r-x) sur le binaire, les devices, les fichiers de
conf, etc
l'appartenance aux groupes "scanner" "usb", etc
un détail : avec les noyaux 2.6, il ne faut plus charger le module "scanner"
A+



AGFA e20 usb et MINOLTA SCAN DUAL IV usb.
J'avais fini par faire tourner l'AGFA avec XSANE mais apres des
bidouillages infames ( recopier un fichier SNAPE20.bin dans le pilote WIN
et le mettre dans .sane entre autres..)
Vuescan marchait tres bien sur les deux ( j'ai d'ailleurs achete la
licence)mais impossible de le lancer sous la 2006..

J.D.
jide
Le #8050961
Le Tue, 21 Feb 2006 20:34:13 +0100, Jacques Pronchery a écrit :

jide a écrit :
Bonjour, avec mes scanners pas reconnus, j'utilisais ,sur ma 9.2 ,vuescan
, qui marche tres bien. Je recidive avec la 2006 et.. la cata!
Telechargement sans pb, decompression avec ARK , et j'ai , entre autres,
un magnifique executable ( avec la petite roue dentee )... qui refuse
obstinement de s'executer. Pourtant , dans "proprietes" c'est bien un
executable! Si j'insiste ,le systeme me demande avec quel logiciel je veux
l'ouvrir..
Tout essaye, deplacer les dossiers, recopier les fichiers depuis la 9.2,
rien a faire et je n'ai plus de scanner! Une idee? Merci d'avance
J.D.



Bonjour,

Essaie de le lancer dans une console, il te dira peut-être
pourquoi il ne marche pas.

Jacques.



Bonne idee, je vais voir ca.
Merci a tous des reponses
J.D.
jide
Le #8050901
Le Tue, 21 Feb 2006 20:34:13 +0100, Jacques Pronchery a écrit :

Essaie de le lancer dans une console, il te dira peut-être
pourquoi il ne marche pas.



Je passe dans le dossier Vuescan , je fais un dir qui confirme que c'est
bien la que se trouve le prg vuescan, je tape vuescan et Return, j'ai:

# bash: vuescan command not found

Idem en root. Une idee?
Merci
J.D.
Jacques Pronchery
Le #8050871
jide a écrit :
Le Tue, 21 Feb 2006 20:34:13 +0100, Jacques Pronchery a écrit :


Essaie de le lancer dans une console, il te dira peut-être
pourquoi il ne marche pas.




Je passe dans le dossier Vuescan , je fais un dir qui confirme que c'est
bien la que se trouve le prg vuescan, je tape vuescan et Return, j'ai:

# bash: vuescan command not found

Idem en root. Une idee?
Merci
J.D.




Si tu tapes vuescan il va chercher dans les répertoire indiquer dans
le PATH c'est à dire dans les répertoires bin.

Si tu as été dans le bon répertoire tu tapes ./vuescan
sinon dans n'importe quel répertoire il faut indiquer le chemin complet
soit /usr/...../vuescan.

Je pense que dans ton menu tu n'as pas indiqué le chemin complet.

Une autre méthode c'est de faire un lien dans le répertoire /usr/bin ou
dans le répertoire /usr/local/bin

Jacques.
Jacques Pronchery
Le #8050821
jide a écrit :
Le Tue, 21 Feb 2006 20:34:13 +0100, Jacques Pronchery a écrit :


Essaie de le lancer dans une console, il te dira peut-être
pourquoi il ne marche pas.




Je passe dans le dossier Vuescan , je fais un dir qui confirme que c'est
bien la que se trouve le prg vuescan, je tape vuescan et Return, j'ai:

# bash: vuescan command not found

Idem en root. Une idee?
Merci
J.D.




Je viens de télécharger et installer VueScan et ça marche très bien
sous Mandriva 2005.
Je pense que ma réponse précédente est la bonne.

Jacques.
jide
Le #8050801
Le Wed, 22 Feb 2006 19:14:28 +0100, Jacques Pronchery a écrit :


Si tu tapes vuescan il va chercher dans les répertoire indiquer dans
le PATH c'est à dire dans les répertoires bin.

Si tu as été dans le bon répertoire tu tapes ./vuescan
sinon dans n'importe quel répertoire il faut indiquer le chemin complet
soit /usr/...../vuescan.

Je pense que dans ton menu tu n'as pas indiqué le chemin complet.

Une autre méthode c'est de faire un lien dans le répertoire /usr/bin ou
dans le répertoire /usr/local/bin



Mais si je me trouve dans le repertoire ou est installe vuescan, je pense
que le logiciel vuescan qui s'y trouve devrait se lancer. Mais je me
trompe peut etre et je vais essayer
Merci de la reponse
J.D.
jide
Le #8050791
Le Wed, 22 Feb 2006 19:14:28 +0100, Jacques Pronchery a écrit :


Si tu as été dans le bon répertoire tu tapes ./vuescan
sinon dans n'importe quel répertoire il faut indiquer le chemin complet
soit /usr/...../vuescan.

Je pense que dans ton menu tu n'as pas indiqué le chemin complet.

Une autre méthode c'est de faire un lien dans le répertoire /usr/bin ou
dans le répertoire /usr/local/bin



Effectivement, en tapant ./vuescan il se passe quelque chose mais..

html purchase.htm upgrade.htm vuescan vuescan.bmp vuescan.dat vuescan.htm
bash-3.00$ ./vuescan
./vuescan: error while loading shared libraries: libstdc++.so.5: cannot open sha red object file: No such file or directory
bash-3.00$

Apparemment il manque quelque chose?
J.D.
sansflotusspam
Le #8050781
jide a écrit :

Le Wed, 22 Feb 2006 19:14:28 +0100, Jacques Pronchery a écrit :


Si tu as été dans le bon répertoire tu tapes ./vuescan
sinon dans n'importe quel répertoire il faut indiquer le chemin complet
soit /usr/...../vuescan.

Je pense que dans ton menu tu n'as pas indiqué le chemin complet.

Une autre méthode c'est de faire un lien dans le répertoire /usr/bin ou
dans le répertoire /usr/local/bin



Effectivement, en tapant ./vuescan il se passe quelque chose mais..

html purchase.htm upgrade.htm vuescan vuescan.bmp vuescan.dat
vuescan.htm bash-3.00$ ./vuescan
./vuescan: error while loading shared libraries: libstdc++.so.5: cannot
open sha red object file: No such file or directory
bash-3.00$

Apparemment il manque quelque chose?
J.D.



vuescan veut une version précise de libstc++.so.5
pour savoir laquelle, faire ldd /chemin_complet_vers_vuescan/vuescan,
repérer le lien manquant et/ou vide, c.a.d. le nom exact de la (les) libs
exigées,
si il y a bien une libstdc++.so.5.et_quelquechose dans /ust/lib/, faire un
lien symbolique "nom de la lib5 demandée par vuescan" sur la
libstdc++.so.5.xxxx installée
ce n'est pas totalement garanti, mais ça peut marcher.
drnière solution : trouver (avec rpmfind, par ex) la version exacte demandée
par vuescan.
A+
Poster une réponse
Anonyme