Installation GCC !!!

Le
CoReY
Bonjour à tous,

Je possède actuellement une Mandriva 2006 64 bits. Je voudrais installer
certains programme mais on me demande gcc, j'ai le paquetage gcc-cpp
4.0.1-5mdk d'installer mais lorsque j'essaie ça me fait:
checking for gcc no
checking for cc no
checking for cc no
checking for cl no
configure: error: no acceptable C compiler found in $PATH
Je me suis dit sans doute que gcc n'est pas installé alors j'ai tenté de
le faire et j'obtiens:
urpmi gcc
Un des paquetages suivants est nécessaire :
1- kernel-source-2.6-2.6.12-22mdk.x86_64 : The source code for the
Linux kernel. (to install)
2- kernel-source-stripped-2.6-2.6.12-22mdk.x86_64 : The source code of
the Linux kernel stripped for post build. (to install)
3- kernel-multimedia-source-2.6.12-12.mm.3mdk.i586 : The source code
for the Linux kernel (to install)
Quelle option et est-ce que je dois choisir ?
Je suis débutant sous Linux merci !
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
sansflotusspam
Le #7945911
CoReY wrote:

Bonjour à tous,

Je possède actuellement une Mandriva 2006 64 bits. Je voudrais installer
certains programme mais on me demande gcc, j'ai le paquetage gcc-cpp
4.0.1-5mdk d'installÉ mais lorsque j'essaie ça me fait:
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
Je me suis dit sans doute que gcc n'est pas installé



ben là, oui, c'est évident !
gcc-cpp, c'est l'extension C++ de gcc

alors j'ai tenté de le faire et j'obtiens:
urpmi gcc
Un des paquetages suivants est nécessaire :
1- kernel-source-2.6-2.6.12-22mdk.x86_64 : The source code for the
Linux kernel. (to install)



le normal minimum

2- kernel-source-stripped-2.6-2.6.12-22mdk.x86_64 : The source code of
the Linux kernel stripped for post build. (to install)



le strict minimum, pour mini-mini-machins (on pourrait dire "cliped, craped,
croped"

3- kernel-multimedia-source-2.6.12-12.mm.3mdk.i586 : The source code
for the Linux kernel (to install)



le source de base + le multimedia (son+video+..)

Quelle option et est-ce que je dois choisir ?
Je suis débutant sous Linux merci !



prends le kernel-multimedia-source, au moins, mais le "kit" "développement"
a bien d'autres outils, souvent nécessaires.
tu peux commencer par une mise à jour de ta distrib en sélectionnant les
packages "développement", ça peut servir.
A+
CoReY
Le #7945901
CoReY a écrit :
Bonjour à tous,

Je possède actuellement une Mandriva 2006 64 bits. Je voudrais installer
certains programme mais on me demande gcc, j'ai le paquetage gcc-cpp
4.0.1-5mdk d'installer mais lorsque j'essaie ça me fait:
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
Je me suis dit sans doute que gcc n'est pas installé alors j'ai tenté de
le faire et j'obtiens:
urpmi gcc
Un des paquetages suivants est nécessaire :
1- kernel-source-2.6-2.6.12-22mdk.x86_64 : The source code for the
Linux kernel. (to install)
2- kernel-source-stripped-2.6-2.6.12-22mdk.x86_64 : The source code of
the Linux kernel stripped for post build. (to install)
3- kernel-multimedia-source-2.6.12-12.mm.3mdk.i586 : The source code
for the Linux kernel (to install)
Quelle option et est-ce que je dois choisir ?
Je suis débutant sous Linux merci !



J'ai essayé de faire ce que vous m'avez dit mais lorsque je choisis
l'une des trois options l'ordinateur ne réagit pas...Je ne sais pas à
quoi cela est dû !
clocard
Le #7945871
>> Un des paquetages suivants est nécessaire :
1- kernel-source-2.6-2.6.12-22mdk.x86_64 : The source code for the
Linux kernel. (to install)
2- kernel-source-stripped-2.6-2.6.12-22mdk.x86_64 : The source code of
the Linux kernel stripped for post build. (to install)
3- kernel-multimedia-source-2.6.12-12.mm.3mdk.i586 : The source code
for the Linux kernel (to install)
Quelle option et est-ce que je dois choisir ?
Je suis débutant sous Linux merci !



J'ai essayé de faire ce que vous m'avez dit mais lorsque je choisis
l'une des trois options l'ordinateur ne réagit pas...Je ne sais pas à
quoi cela est dû !



aprés avoir choisis l'option, tu la valides ...
CoReY
Le #7945851
clocard a écrit :
Un des paquetages suivants est nécessaire :
1- kernel-source-2.6-2.6.12-22mdk.x86_64 : The source code for the
Linux kernel. (to install)
2- kernel-source-stripped-2.6-2.6.12-22mdk.x86_64 : The source code of
the Linux kernel stripped for post build. (to install)
3- kernel-multimedia-source-2.6.12-12.mm.3mdk.i586 : The source code
for the Linux kernel (to install)
Quelle option et est-ce que je dois choisir ?
Je suis débutant sous Linux merci !


J'ai essayé de faire ce que vous m'avez dit mais lorsque je choisis
l'une des trois options l'ordinateur ne réagit pas...Je ne sais pas à
quoi cela est dû !



aprés avoir choisis l'option, tu la valides ...



Lol, évidemment...je l'ai fait...
Poster une réponse
Anonyme