Installer un scanner Canon MX320 sous Buster

Le
Olivier
Bonjour,

J'ai une vieille multi-fonction Canon MX320 dotée d'une interface USB.
Je souhaite, dans un premier temps, l'utiliser comme scanner en ligne
de commande sur une machine sous Buster (les fonctions d'impression ne
m'intéressent pas).

Elle est correctement détectée :
# scanimage -L
device `pixma:04A91736_154338' is a CANON Canon PIXMA MX320
multi-function peripheral

Par contre :
# scanimage -d "pixma:04A91736_154338" > /tmp/foo.bar
scanimage: sane_read: Error during device I/O
ou
$scanimage -d "pixma:04A91736_154338" > /tmp/toto
scanimage: sane_read: Error during device I/O

Dans mes logs je vois aussi quand j'allume le scanner:
systemd-udevd[11797]: Process '/bin/setfacl -m g:scanner:rw ' failed
with exit code 2.

1. Quelqu'un a-t-il utilisé avec succès la fonction scanner sous
Buster/x86_64 avec une machine Canon Pixma quelconque ? et sous
Bullseye ?

2. Un conseil ?

Slts
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Christophe Musseau
Le #26583226
--000000000000ee51f605d7731b88
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Le lun. 7 f̓©vr. 2022 ̓  19:55, Olivier
Bonjour,
J'ai une vieille multi-fonction Canon MX320 dot̓©e d'une interface USB.
Je souhaite, dans un premier temps, l'utiliser comme scanner en ligne
de commande sur une machine sous Buster (les fonctions d'impression ne
m'int̓©ressent pas).
Elle est correctement d̓©tect̓©e :
# scanimage -L
device `pixma:04A91736_154338' is a CANON Canon PIXMA MX320
multi-function peripheral
Par contre :
# scanimage -d "pixma:04A91736_154338" > /tmp/foo.bar
scanimage: sane_read: Error during device I/O
ou
$scanimage -d "pixma:04A91736_154338" > /tmp/toto
scanimage: sane_read: Error during device I/O
Dans mes logs je vois aussi quand j'allume le scanner:
systemd-udevd[11797]: Process '/bin/setfacl -m g:scanner:rw ' failed
with exit code 2.
1. Quelqu'un a-t-il utilis̓© avec succ̓¨s la fonction scanner sous
Buster/x86_64 avec une machine Canon Pixma quelconque ? et sous
Bullseye ?
2. Un conseil ?
Slts


Bonjour
Sur le site de Canon on trouve divers pilotes pour des machines sous
Gnu/Linux. Y compris des paquets .deb. J'ai pu (et encore aujourd'hui)
utiliser trois ou quatre mod̓¨les Pixma avec Debian, sans souci. Pour le
mod̓¨le MX320 j'ai vu (rapidement) qu'il n'y avait que des pilotes pour i386.
Bonne journ̓©e
--000000000000ee51f605d7731b88
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
<br>
J&#39;ai une vieille multi-fonction Canon MX320 dot̓©e d&#39;une interface USB.<br>
Je souhaite, dans un premier temps, l&#39;utiliser comme scanner en ligne<br>
de commande sur une machine sous Buster (les fonctions d&#39;impression ne<br>
m&#39;int̓©ressent pas).<br>
<br>
Elle est correctement d̓©tect̓©e :<br>
# scanimage -L<br>
device `pixma:04A91736_154338&#39; is a CANON Canon PIXMA MX320<br>
multi-function peripheral<br>
<br>
Par contre :<br>
# scanimage -d &quot;pixma:04A91736_154338&quot; &gt; /tmp/foo.bar<br>
scanimage: sane_read: Error during device I/O<br>
ou<br>
$scanimage -d &quot;pixma:04A91736_154338&quot; &gt; /tmp/toto<br>
scanimage: sane_read: Error during device I/O<br>
<br>
Dans mes logs je vois aussi quand j&#39;allume le scanner:<br>
systemd-udevd[11797]: Process &#39;/bin/setfacl -m g:scanner:rw &#39; failed<br>
with exit code 2.<br>
<br>
1. Quelqu&#39;un a-t-il utilis̓© avec succ̓¨s la fonction scanner sous<br>
Buster/x86_64 avec une machine Canon Pixma quelconque ? et sous<br>
Bullseye ?<br>
<br>
2. Un conseil ?<br>
<br>
Slts<br>
<br>
--000000000000ee51f605d7731b88--
Olivier
Le #26583239
J'ai vu la même chose que toi: des pilotes canon mais pour une machine
i386 alors que la mienne est x86_64.
Par chance, la machine Í  laquelle est connecté ce scanner héberge des VM (KVM).
Peut-être qu'en dédiant une VM 32 bits Í  ça, je pourrai retomber sur mes pattes.
Le lun. 7 févr. 2022 Í  21:04, Christophe Musseau

Le lun. 7 févr. 2022 Í  19:55, Olivier
Bonjour,
J'ai une vieille multi-fonction Canon MX320 dotée d'une interface USB.
Je souhaite, dans un premier temps, l'utiliser comme scanner en ligne
de commande sur une machine sous Buster (les fonctions d'impression ne
m'intéressent pas).
Elle est correctement détectée :
# scanimage -L
device `pixma:04A91736_154338' is a CANON Canon PIXMA MX320
multi-function peripheral
Par contre :
# scanimage -d "pixma:04A91736_154338" > /tmp/foo.bar
scanimage: sane_read: Error during device I/O
ou
$scanimage -d "pixma:04A91736_154338" > /tmp/toto
scanimage: sane_read: Error during device I/O
Dans mes logs je vois aussi quand j'allume le scanner:
systemd-udevd[11797]: Process '/bin/setfacl -m g:scanner:rw ' failed
with exit code 2.
1. Quelqu'un a-t-il utilisé avec succès la fonction scanner sous
Buster/x86_64 avec une machine Canon Pixma quelconque ? et sous
Bullseye ?
2. Un conseil ?
Slts


Bonjour

Sur le site de Canon on trouve divers pilotes pour des machines sous Gnu/Linux. Y compris des paquets .deb. J'ai pu (et encore aujourd'hui) utiliser trois ou quatre modèles Pixma avec Debian, sans souci. Pour le modèle MX320 j'ai vu (rapidement) qu'il n'y avait que des pilotes pour i386.
Bonne journée
didier gaumet
Le #26583251
une petite recherche "scangear deb" amène sur le site canadien de Canon o͹ la version scangear2 4.10 relativement récente (2020) est téléchargeable, comprenant les versions 32 et 64 bits:
https://canoncanadafr.custhelp.com/app/answers/answer_view/a_id/1034243/~/scangear-mp-v.-4.10-for-linux-%28debian-packagearchive%29
Olivier
Le #26583299
Merci beaucoup, Didier, pour l'info.
J'ai pu installer Scangear mais j'ai toujours le même message d'erreur
(enigmatique) avec scanimage.
Peut-être que scanimage (ou sane plus généralement) n'utilise tout
simplement ni Scangear ni les pilotes apportés par Scangear ?
Le mar. 8 févr. 2022 Í  14:06, didier gaumet
une petite recherche "scangear deb" amène sur le site canadien de Canon o͹ la version scangear2 4.10 relativement récente (2020) est téléchargeable, comprenant les versions 32 et 64 bits:
https://canoncanadafr.custhelp.com/app/answers/answer_view/a_id/1034243/~/scangear-mp-v.-4.10-for-linux-%28debian-packagearchive%29
Kohler Gerard
Le #26583301
bonjour,
je me suis heurté Í  ces problèmes et j'ai du me résoudre Í  quitter le
libre (mais un scanner est-il libre ?) pour passer du coté plus sombre.
si vraiment l'utilisation de ton scanner est impérative je te conseil
Vuescan, c'est pas libre c'est payant (modique) mais cela marche super
bien et surtout, pour moi, on retrouve toutes les fonctions
propriétaires du matériel. Dans mon cas (scan de négatifs de grande
taille) j'ai même la fonction anti-poussière.
Apparemment ton scanner est supporté
Gérard
Le 09/02/2022 Í  09:31, Olivier a écrit :
Merci beaucoup, Didier, pour l'info.
J'ai pu installer Scangear mais j'ai toujours le même message d'erreur
(enigmatique) avec scanimage.
Peut-être que scanimage (ou sane plus généralement) n'utilise tout
simplement ni Scangear ni les pilotes apportés par Scangear ?
didier gaumet
Le #26583303
Oui, a priori c'est exactement ça, la solution Canon est globale (logiciel et pilotes) et différente de Sane, il n'y a donc pas d'intégration avec Sane:
https://wiki.debian.org/Scanner#Non-free_Scanner_Backends
Il faut donc utiliser le logiciel Scangear pour scanner
Si c'était un modèle plus récent avec possibilité de scanner par le réseau, tu pourrais utiliser le pilote sane-airscan et les outils qui s'appuient sur sane, mais ce n'est pas le cas, apparemment.
Poster une réponse
Anonyme