mozilla est-il vraiment mon client mail par defaut ?

Le
Pisaura Mirabilis
Salut à tous,

x-post fr.comp.lang.pascal et fr.comp.mail suivi dans ce dernier (que je
découvre en même temps et ou je salue les habitués - c'était le fayottage
du nouveau pour essayer de s'attirer la sympathie de la foule)

pas sûr que ce soit en charte sur fr.comp.mail, c'est de la prog mais il
semblerait que mon code source soit correct, alors je voudrait savoir si
c'est un pb de config chez moi, un problème propre à mozilla ou autre
chose

config : XPpro sp1, moz 1.7.3 environnement de dév. Delphi 4

J'ai un chti' soft ou je veux mettre un lien bibi@chezmoi.con (*) dans la
boite "à propos" pour que mes nombreux utilisateurs puissent m'insulter
entre deux plantages.

le code est le suivant :

procedure TAboutBox.LabelMailClick(Sender: TObject);
var email, destinataire, sujet :String;
begin
destinataire:='bibi@chezmoi.con';
sujet:='Soft qui fait rien qu''a planter';
email:='mailto:' + destinataire + '?subject=' + sujet;
ShellExecute (Self.Handle,'open',PChar(email),nil,nil,SW_SHOW);
end;

Un click à l'endroit adéquat lance OE ! Pas glop'

Dans la BdR j'ai effectivement :

[HKEY_CLASSES_ROOTmailtoshellopencommand]
@=hex(2):22,00,25,00,50,00,72,00,6f,00,67,00,72,00,61,00,6d,00,46,00,69,00,6c,
00,65,00,73,00,25,00,5c,00,4f,00,75,00,74,00,6c,00,6f,00,6f,00,6b,00,20,00,
45,00,78,00,70,00,72,00,65,00,73,00,73,00,5c,00,6d,00,73,00,69,00,6d,00,6e,
00,2e,00,65,00,78,00,65,00,22,00,20,00,2f,00,6d,00,61,00,69,00,6c,00,75,00,
72,00,6c,00,3a,00,25,00,31,00,00,00

ce qui ne signifie rien de moins que :
"%ProgramFiles%Outlook Expressmsimn.exe" /mailurl:%1

Il est donc "normal" que OE se lance mais pourtant, j'ai bien configuré
mozilla pour être client mail par défaut (la reconfiguration n'a rien donné
et il semblerait que ce soit la même chose chez d'autres)

D'où mes questions :
- est-ce un comportement dû à Mozilla ? (bug ?)
- est le crétin (moi) qui a installé Mozilla qui aurait dû retiré ses
moufles ?
- comment faire pour ouvrir "vraiment" le client mail par défaut ?

Les réponses à la dernière question pourront se faire de préférence sur
fr.comp.lang.pascal.

Merci d'avance.
--
PM

(*) amis spammeurs : vous pouvez toujours spammer cette adresse
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Fabien LE LEZ
Le #224276
On Wed, 23 Feb 2005 14:48:44 +0100, Pisaura Mirabilis
Un click à l'endroit adéquat lance OE ! Pas glop'


Crée une page contenant

</html>

Ouvre cette page dans Internet Explorer et clique sur le lien. Que se
passe-t-il ?



--
;-)

Pisaura Mirabilis
Le #224275

Ouvre cette page dans Internet Explorer et clique sur le lien. Que se
passe-t-il ?


Je viens de vérifier IE comme FF m'ouvrent OE sur les liens mailto:
C'est logique par rapport à la configuration de Windows.
--
PM

Pisaura Mirabilis
Le #224273

Wed, 23 Feb 2005 14:48:44 +0100, Pisaura Mirabilis
Il est donc "normal" que OE se lance mais pourtant, j'ai bien configuré
mozilla pour être client mail par défaut


Uniquement dans Mozilla ou aussi dans le panneau de config ?


C'est bien le cas j'ai "Mozilla Courrier" comme programme de courrier !
J'ai fait une modif, puis rémis ce réglage : rien de changé !
--
PM


Pisaura Mirabilis
Le #224271

- Décoche Mozilla comme client courrier
- Referme-le
- Ouvre OE
- Défini-le comme client mail
- Referme-le
- Réouvre Mozilla
- Défini-le comme client mail
- Referme-le


marche pas :-( !

c'est normal ?
--
PM

Steph.K
Le #224270
[...]
marche pas :-( !

c'est normal ?


Est-ce que tu as essayé :
Démarrer ==> Configurer les programmes par défaut ==> Personnalisée
Tu règles tes préférences et tu rebootes.
Fonctionne avec XP SP2

--
Steph.K
http://www.acces-pour-tous.net

Fabien LE LEZ
Le #224235
On Wed, 23 Feb 2005 14:48:44 +0100, Pisaura Mirabilis
Dans la BdR j'ai effectivement :

[HKEY_CLASSES_ROOTmailtoshellopencommand]
@=hex(2):22,00,25,00,[...],00,00,00

ce qui ne signifie rien de moins que :
"%ProgramFiles%Outlook Expressmsimn.exe" /mailurl:%1


N'as-tu pas moyen de changer directement cette valeur à la main ?


--
;-)

Pisaura Mirabilis
Le #224031

Est-ce que tu as essayé :
Démarrer ==> Configurer les programmes par défaut ==> Personnalisée
Tu règles tes préférences et tu rebootes.
Fonctionne avec XP SP2


message d'erreur, il cherche un clé relative à un mozilla english :
HKLMsoftwaremozilla.orgMozilla1.7.3(en)UninstallUnistall Log Folder
alors que j'ai bien :
HKLMsoftwaremozilla.orgMozilla1.7.3(fr)UninstallUnistall Log Folder

laissez tomber, je vais attendre la sortie de la 1.7.5 francisée et je
réinstalle tout ça !

Merci à tous...
--
PM

Poster une réponse
Anonyme