probleme avec DIV/0 et Moyenne

Le
Cédric
Bonjour

J'ai des moyennes a faire sur plusieurs lignes. Ces lignes sont des
divisions donc lorsque je fait ma division et que c'est 0 cela m'affiche
comme moyenne de ma ligne DIV/0 et si j'utilise la fonction SI pour cacher le
div/0 alors ma moyenne est fossé car il prend en compte la ligne meme s'il n'
a rien dedans

Y a t'il une solution pour lui dire de ne prendre que les lignes ayant un
chiffre et d'eviter ceux avec div/0

Merci
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
AV
Le #3698291
| Y a t'il une solution pour lui dire de ne prendre que les lignes ayant un
| chiffre et d'eviter ceux avec div/0

matricielle :
=MOYENNE(SI(ESTNUM(notes);notes))

AV
Yoyo
Le #3698261
Salut Cédric

tu devrais essayer ta moyenne avec la formule =NB.SI(G2:G7;">0")
elle compte le nombre de czllule non vide

cordialement yoyo




Bonjour

J'ai des moyennes a faire sur plusieurs lignes. Ces lignes sont des
divisions donc lorsque je fait ma division et que c'est 0 cela m'affiche
comme moyenne de ma ligne DIV/0 et si j'utilise la fonction SI pour cache r le
div/0 alors ma moyenne est fossé car il prend en compte la ligne meme s 'il n'
a rien dedans

Y a t'il une solution pour lui dire de ne prendre que les lignes ayant un
chiffre et d'eviter ceux avec div/0

Merci


Yoyo
Le #3698251
Salut Cédric

tu devrais essayer ta moyenne avec la formule =NB.SI(G2:G7;">0")
elle compte le nombre de czllule non vide

cordialement yoyo




Bonjour

J'ai des moyennes a faire sur plusieurs lignes. Ces lignes sont des
divisions donc lorsque je fait ma division et que c'est 0 cela m'affiche
comme moyenne de ma ligne DIV/0 et si j'utilise la fonction SI pour cache r le
div/0 alors ma moyenne est fossé car il prend en compte la ligne meme s 'il n'
a rien dedans

Y a t'il une solution pour lui dire de ne prendre que les lignes ayant un
chiffre et d'eviter ceux avec div/0

Merci


Jacky
Le #3698241
Bonsoir,
Une .....
=SOMME(plage)/NB(plage)

Salutations
JJ

"Cédric" news:
Bonjour

J'ai des moyennes a faire sur plusieurs lignes. Ces lignes sont des
divisions donc lorsque je fait ma division et que c'est 0 cela m'affiche
comme moyenne de ma ligne DIV/0 et si j'utilise la fonction SI pour cacher
le

div/0 alors ma moyenne est fossé car il prend en compte la ligne meme s'il
n'

a rien dedans

Y a t'il une solution pour lui dire de ne prendre que les lignes ayant un
chiffre et d'eviter ceux avec div/0

Merci


Poster une réponse
Anonyme