Windows 7 - 64bits : Contrôle d'occurence sur deux colonnes VBA

Le
Bryard offline Hors ligne
Bonjour à tous,

Je souhaiterai réaliser un contrôle par macro VBA sur deux colonnes Excel :

Colonne A Colonne B

15654789 LL01-5634
15654789 LL01-5634
15654789 MP01-5464

si dans col A j'ai 15654789 et dans col B LL01-5634 alors je veux vérifier qu'à chaque fois que j'aurai 15654789 dans ma col A j'aurai LL01-5634 dans ma col B sinon je renvoie un message d'erreur. je souhaiterai généraliser cela avec plusieurs références différentes dans Col A
j'ai pu le faire manuellement comme ceci :

=SI(NB.SI($A$2:A2;A2)=NB.SI.ENS($A$2:A2;A2;$G$2:G2;B2);"OK";"KO")

Merci beaucoup !!!
  • Partager ce contenu :
Vos réponses
Poster une réponse
Anonyme